Продолжение истории про openSUSE Leap 15.2 и безнадёжно устаревшую видео карту
Поддержать
Загрузить свой скриншот
Войдите, чтобы добавлять скриншоты

Продолжение истории про openSUSE Leap 15.2 и безнадёжно устаревшую видео карту

26
Дистрибутив:
Окружение:

И снова здравствуйте :-) Всех завсегдатых я категорически приветствую :)

Маленький но очень назойливый перфекционист внутри меня не давал мне покоя, заставляя бродить по просторам всемирной паутины в поисках информации, как всё-таки поставить драйвер на GeForce 9600…

И… и… и как видно на скриншоте, таки нашел :)
Мог найти и раньше, если б знал французский. Помогла статья по этой ссылке https://blog.microlinux.fr/nvidia-geforce-9400-opensuse-leap-15-2/
Автор француз и статья на французском поэтому несколько раз проходил мимо.

Итак, после того, как я её перевёл на английский мне стало ясно, что прежде чем устанавливать драйвер из run файла, его нужно пропатчить. С этим, как раз, мисье француз здорово помог, оставив ссылку на патч прямо в статье.

Вообщем так, качаем драйвер с сайта nvidia потом его патчим (как это сделать в статье по ссылке) выходим в консоль alt+ctl+ f1
Вбиваем по очереди
# systemctl set-default multi-user.target
# systemctl isolate multi-user.target

Это включит графику, то есть будет только консоль.
Теперь нужно отключить загрузку nuoveau
Если прежде дров от nvidia не стояло как умения то команда вот такая, с opensuse.wiki
# echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf && mkinitrd && reboot

Теперь перезагрузка, в grub жмём E и в строке параметров ядра дописываем вот это: nomodeset. А mitigations меняем с auto на off
Загрузка произойдет в консоль, логинимся и запускаем установку драйвера. Команды для этого дублировать не вижу смысла.

Но прежде нужно подготовить инсталлятор, то есть пропатчить, как это сделать, мисье написал. И установить вот это
# zypper install --no-recommends gcc patch kernel-default-devel libglvnd-devel

Я описал те действия которые мне не сразу были понятны, может кому пригодиться.

Прежде чем поделиться со всеми своими приключениями, я успел узнать что заблуждался по поводу обновлений ядра, то есть я думал что оно больше обновляться не будет, но нет, приходят всякие обновления безопасности и прочие исправления после которых процедуру установки нужно повторять, но это не проблема если хранить пропатченый драйвер в доступном месте.

И не много про последствия, очень сильно возросло потребление оперативки почти в двое. Но и это не смертельно если использовать zram, он тут заводиться установкой пары пакетов, вида, zram-settings. Меня реально спасал. И мир не без добрых людей, мне знакомый подарил ещё 4 гига ни кому не нужной DDR2 :) правда скриншот я сделал ещё без них.

На этом у меня всё, всем добра :)

Лайков: +13
войдите, чтобы ставить лайки
26
  • Опубликовано: 14.02.2021
  • Mrsvx81

Еще скриншоты:



Комментарии

Minor748
Активный пользователь
Активный
14.02.2021
11:29
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
+1
войдите, чтобы ставить лайки
Вот и я смотрю, что уж очень ОЗУ мало.
А КДЕ как себя тут чувствует ?
Mrsvx81
Активный пользователь
Активный
Автор материала
Автор материала
14.02.2021
11:32
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
+2
войдите, чтобы ставить лайки
Сейчас всё отлично, двух гигов было в притык, но на шести можно жить припеваючи :)
OldRunner
Активный пользователь
Активный
14.02.2021
12:47
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
100%
Polzovatel
14.02.2021
12:34
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
0
войдите, чтобы ставить лайки
Я кстати вчера ставил Сузю с КДЕ на Raspberry pi, но там небыло никаколо языка, кроме английского. Печально, поэтому я вернулся на манжару с тем же КДЕ.
Mrsvx81
Активный пользователь
Активный
Автор материала
Автор материала
14.02.2021
13:02
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Возможно ARM версию просто некому переводить? Русско язычное сообщество у этого дистра не так велико сейчас как у Манжаро и арча, про убунту вообще молчу.
OldRunner
Активный пользователь
Активный
14.02.2021
16:02
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
+1
войдите, чтобы ставить лайки
А я установил и пользую rolling версию "Tumbleweed" - она мне, почему-то, больше понравилась.
Mrsvx81
Активный пользователь
Активный
Автор материала
Автор материала
14.02.2021
16:19
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Ну как-бы пласма там последней версии, с новыми фишками и т.д и т.п.
Ме, rolling больше не подходит. Ещё одно бновление иксов, и всё, старый драйвер для nvidia не взлетит. Если я правильно понял, то версия x.org 1.20 последняя которая поддерживает nvidia 340.108. С ядром как-то разобрался но тут для меня тёмный лес совсем.
OldRunner
Активный пользователь
Активный
14.02.2021
16:32
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Понятно. А жаль.
Тогда придется уходить на Арч и ставить ядро lts - там еще поддерживаются старые верси, как мне кажется.
dakaer
Активный пользователь
Активный
14.02.2021
18:47
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
+1
войдите, чтобы ставить лайки
у меня же она более стабильная, без отвала сетевухи
[аноним]
14.02.2021
16:07
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
-10
войдите, чтобы ставить лайки
ставьте EndeavourOS Deepin не пожалеете)Это вынос мозга, красота и арч. Какие найк KDE и Gnome, тут deepin сладенький
OldRunner
Активный пользователь
Активный
14.02.2021
16:34
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
+2
войдите, чтобы ставить лайки
Вернитесь к своему мозгу, дружище - не отрывайтесь далеко! :-))
[аноним]
14.02.2021
16:16
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
0
войдите, чтобы ставить лайки
Пацаны как установить магазин приложений в арче)
OldRunner
Активный пользователь
Активный
14.02.2021
16:30
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
sudo pacman -S pamac
[аноним]
14.02.2021
16:49
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
да ладно? Я по другой инструкции кучу команд вводил)
Sergejs
Активный пользователь
Активный
14.02.2021
23:56
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Ты какие команды вводил?надеюсь Pamac c yay установил а не yaourt,да и ставить нужно пакет pamac-aur
dakaer
Активный пользователь
Активный
14.02.2021
18:50
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
+1
войдите, чтобы ставить лайки
sudo pacman -S magazin
Алексей
15.02.2021
09:19
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
-10
войдите, чтобы ставить лайки
Сколько не пляши, а тормазной ваш этот OpenSuse, пробовал месяц назад, про KDE молчу, вообще каша с настройками, про кодеки и т.п. тоже молчу.... жесть. Усановка длится оокло часа. Не рекомендую.
Cyber
Активный пользователь
Активный
15.02.2021
20:39
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
0
войдите, чтобы ставить лайки
У меня тоже карточка 9600 GT, на Linux Mint дрова ставятся из настроек системы, без танцев с бубном :)
Mrsvx81
Активный пользователь
Активный
Автор материала
Автор материала
15.02.2021
22:39
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Какая версия минта? Давно им не пользуюсь, последний с которым имел дело был 19.1, там да с дровами к этой карте проблем небыло. Но на данный момент, из монжаро например поддержку вырезали, вот была в ядре 5.4 и вдруг не стало, сразу после того как сама nvidia от неё отказалась, подозреваю что и в последней версии минт будет тоже самое.
Cyber
Активный пользователь
Активный
16.02.2021
10:01
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
20-я
В предыдущих тоже нормально работало
В плане установки нормально устанавливалось, работало и работает на убунте/минте/слаке (но на слаке с сайта надо драйвер брать)
на опенсуси часто очень часто был тиринг который надо было как то лечить....
Mrsvx81
Активный пользователь
Активный
Автор материала
Автор материала
16.02.2021
14:42
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Ну что-ж, возможно я сделал не правильный выбор и получил некоторое количество головняка. Просто других проблем у меня с этим дистребутивом нет, ни тиринга ни чего-то ещё.И кеды мне очень зашли, в минте от них отказались.
Cyber
Активный пользователь
Активный
17.02.2021
08:04
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Так то нормально, опенсусей можно пользоваться, только телодвижений больше.... хотя какой то "изюм" эта система добавляет)))
P.S. система по параметрам похожа на мою у меня тоже был DDR2 - 2 гб, видео тоже самое, только проц был от интел Core 2 Quad. Системник от компании Kraftway.
MB1441
Активный пользователь
Активный
17.02.2021
00:57
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
0
войдите, чтобы ставить лайки
На обои живые бабы не нравятся? Или ещё такую тему не проходили?
com
30.04.2021
15:55
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
0
войдите, чтобы ставить лайки
Тоже 340 nvidia есть а g03 выпилили из суси и дебиана 11 теперь только ubuntu ну или mint с ppa от kelebek333
com
29.08.2021
16:17
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
0
войдите, чтобы ставить лайки
Дополню старый коммент теперь везде выпилили кроме rpmfusion и aur
com
29.08.2021
16:24
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
0
войдите, чтобы ставить лайки
software.opensuse.org/package/nvidia-gfxG03 собрали 15.2

Написать комментарий

Ваше имя:
Текст комментария:
  • Уважать других.
  • Не ругаться.
  • Без оскорблений.
  • Без грубости.
  • Не переходить на личности.
  • Писать на русском языке.
  • Без политики.
  • Без флуда.
Правила