Ошибка установки обновлений в Ubuntu

Ошибка установки обновлений в Ubuntu

44
В один прекрасный день перестали устанавливаться обновления в Ubuntu.

При выполнении sudo apt-get update возникает ошибка:
W: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.
E: Encountered a section with no Package: header
E: Problem with MergeList /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_universe_binary-i386_Packages
E: Списки пакетов или файл состояния не могут быть открыты или прочитаны.

В области задач появилось сообщение:
Произошла ошибка. Пожалуйста, запустите менеджер пакетов из меню или введите команду sudo apt-get-f в терминале, чтобы увидеть что произошло и исправить ошибку.
Сообщение об ошибке: "Ошибка: открытие временных файлов (E: Encountered a section with no Package: header, E:Problem with Mergelist /var/lib/apt/lists/ru.archive.ubuntu.com_ubuntu_dists_precise-updates_multiverse_binary-i386_Packages, E: The package lists or status file could not be parsed or opened.)".
Обычно это означает, что ваши установленные пакеты имеют неразрешенные зависимости.

Как исправить эти ошибки?
Выполните в терминале следующие команды:
sudo rm -vf /var/lib/apt/lists/*
sudo apt-get update

Это должно решить проблему.

Комментарии

[аноним]
31.08.2013, 20:12
Постоянная ссылка на комментарий
Нет, это не решает проблему.
[аноним]
25.04.2014, 23:38
Постоянная ссылка на комментарий
СПАСИБО! Помогло.
[аноним]
29.05.2014, 16:39
Постоянная ссылка на комментарий
Для этой проблемы существует одно простое решение. Запустите терминал и выполните в нем по очереди следующие команды:

sudo rm -rf /var/lib/apt/lists/*
sudo apt-get clean
sudo apt-get update
[аноним]
14.08.2014, 16:04
Постоянная ссылка на комментарийРодительский комментарий
спасибо вам огромное, 2 часа гугления дало результат благодаря вам.
[аноним]
06.02.2015, 15:27
Постоянная ссылка на комментарийРодительский комментарий
Спасибо!!! Решилось с Вашей помощью.
[аноним]
21.06.2018, 23:47
Постоянная ссылка на комментарийРодительский комментарий
Спасибо! все работает!
VadimAndyАктивный
02.06.2014, 14:21
Постоянная ссылка на комментарий
Обновления в Ubuntu ставятся
sudo apt-get update && sudo apt-get upgrade - для ПО системы
sudo do-release-upgrade - обновление настоящего релиза Ubuntu
[аноним]
25.03.2016, 15:18
Постоянная ссылка на комментарийРодительский комментарий
первое: sudo rm -vf /var/lib/apt/lists/*
sudo apt-get update

затем: sudo rm -rf /var/lib/apt/lists/*
sudo apt-get clean
sudo apt-get update

и после: sudo apt-get upgrade

И все заработало на линукс роза.

Благодарю!
VadimAndyАктивный
22.08.2016, 11:59
Постоянная ссылка на комментарийРодительский комментарий
уважаемый, обновление всегда ставилось в ubuntu так как показал я. если у вас дистрибутив был другой с самого начала, то это были чисто ваши проблемы
nessАктивный
02.09.2017, 21:15
Постоянная ссылка на комментарийРодительский комментарий
он это самое обновление "чинит", твоя команда в конкретно этом случает не сработает. если бы просто решалось при помощи sudo apt-get update, тогда и темы бы этой с комментами не было.
[аноним]
26.08.2017, 13:39
Постоянная ссылка на комментарийРодительский комментарий
Метод работает.
VadimAndyАктивный
22.06.2018, 12:55
Постоянная ссылка на комментарийРодительский комментарий
ты бесстрашный человек...
sudo rm -rf - вообще забудь...
sudo rm /var/lib/apt/lists/* - для удаления конкретных файлов в директории lists/
sudo apt autoclean - удаление мусора из системы
sudo apt autoremove - удаление зависимостей пакетов, который был удален
[аноним]
29.11.2014, 13:51
Постоянная ссылка на комментарий
Спасибо все работает
[аноним]
15.12.2014, 16:00
Постоянная ссылка на комментарий
У меня получилось! Недуг отступил! Всем большое Благодарю!
[аноним]
22.01.2015, 02:29
Постоянная ссылка на комментарий
sudo rm /var/lib/apt/lists/* -vf
sudo apt-get update
это тоже очень хорошее лекарство
[аноним]
05.08.2015, 13:34
Постоянная ссылка на комментарийРодительский комментарий
Не помогло
VadimAndyАктивный
09.08.2015, 18:59
Постоянная ссылка на комментарийРодительский комментарий
sudo apt-get -f install
sudo apt-get update -y && sudo apt-get upgrade -y
[аноним]
03.11.2015, 15:49
Постоянная ссылка на комментарий
Ничего не помогает ((
[аноним]
21.12.2015, 21:55
Постоянная ссылка на комментарий
Спасибо Андрею, комбинация из 3х команд помогла. У меня Лубунту 14.04LTS
[аноним]
26.12.2015, 22:26
Постоянная ссылка на комментарий
Ничего себе. Столько ссылок открывал, а результата - ноль. Пришёл в итоге сюда и на тебе, проблема решилась.
Спасибо большое автору!
[аноним]
08.01.2016, 16:46
Постоянная ссылка на комментарий
Респект и уважуха! Всё заработало как часы!
[аноним]
25.04.2016, 16:50
Постоянная ссылка на комментарий
не помогло... у меня ubuntu 14.10 utopic unicorn
[аноним]
27.04.2016, 09:34
Постоянная ссылка на комментарийРодительский комментарий
А что вы хотели имея не поддерживаемый более дистрибутив? Обновите до последнего.
[аноним]
22.08.2016, 06:25
Постоянная ссылка на комментарийРодительский комментарий
Как?
VadimAndyАктивный
22.08.2016, 09:54
Постоянная ссылка на комментарийРодительский комментарий
sudo do-release-upgrade в терминале.
[аноним]
29.08.2016, 02:34
Постоянная ссылка на комментарий
Err:12 http://ppa.launchpad.net/tualatrix/ppa/ubuntu xenial/main amd64 Packages
404 Not Found
W: The repository 'http://ppa.launchpad.net/tualatrix/ppa/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/tualatrix/ppa/ubuntu/dists/xenial/main/binary-amd64/Packages 404 Not Found
E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.

объясните мне чайнику?
Перепробовал все, что написано выше Вами.
стоит Ubuntu 16.04.1 LTS
nessАктивный
30.08.2016, 17:23
Постоянная ссылка на комментарийРодительский комментарий
нет пакетов для вашей версии системы. ubuntu tweak в вашем ppa максимум для 14.04, а у вас 16.04. найдите в источниках приложений и удалите ppa:tualatrix/ppa, сделайте sudo apt update, и ошибка пропадет.
[аноним]
02.12.2016, 17:05
Постоянная ссылка на комментарийРодительский комментарий
Спасибо ness и всем причастным ребятам.)
nessАктивный
03.12.2016, 18:12
Постоянная ссылка на комментарийРодительский комментарий
не за что. удачи в освоении системы')
[аноним]
09.01.2017, 00:35
Постоянная ссылка на комментарий
Стоит Ubuntu 16.04 LTS, объясните пожалуйста чайнику что делать с такой ошибкой при обновлении:
W: The repository 'cdrom://Ubuntu 15.04 _Vivid Vervet_ - Release i386 (20150422) vivid Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/chrome/deb stable InRelease' doesn't support architecture 'i386'
W: The repository 'http://www.geekconnection.org/remastersys/repository karmic/ Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch cdrom://Ubuntu 15.04 _Vivid Vervet_ - Release i386 (20150422)/dists/vivid/main/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
E: Failed to fetch http://www.geekconnection.org/karmic/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
nessАктивный
09.01.2017, 20:47
Постоянная ссылка на комментарийРодительский комментарий
как минимум, нужно отключить репозитории 'cdrom://Ubuntu 15.04 _Vivid Vervet.. (обновления с установочного диска, да еще и для 15.04), 'http://dl.google.com/linux/chrome/deb... (пишет же, не поддерживается для 32-битной архитектуры), 'http://www.geekconnection.org/remastersys/... (remastersys версия была новее на launchpad'e, у вас версия еще для 9.10). я такое делаю в synaptic'е, там достаточно просто галки убрать и обновиться. очень удобно').
[аноним]
07.04.2017, 14:15
Постоянная ссылка на комментарий
спасибо. мне помогло
[аноним]
08.04.2017, 22:19
Постоянная ссылка на комментарий
извините а вот мне пишет при обновлении убунту до 16.04
как исправить ? подскажите плиз

Проверка наличия нового релиза Ubuntu
Ваша версия Ubuntu больше не поддерживается.
Traceback (most recent call last):
File "/usr/bin/do-release-upgrade", line 136, in <module>
"%(url)sn") % { 'url' : url })
ValueError: unsupported format character '?' (0xa) at index 55
ruslan@localhost:~$
VadimAndyАктивный
27.06.2018, 15:51
Постоянная ссылка на комментарийРодительский комментарий
sudo do-release -a / sudo apt full-upgrade -y (с ключом y - осторожнее, иначе останавливать команду поздно). Но есть и другой вариант обновить бунту просто пересоберите /etc/apt/sources.list
[аноним]
06.08.2017, 14:34
Постоянная ссылка на комментарий
Доброго времени суток! На Ubuntu 12.04 LTS есть проблема с флеш-плеером. Вообще кучу ошибок всегда находит. Помогите!!! Может имеет смысл залить просто другую версию?
VadimAndyАктивный
13.08.2017, 09:46
Постоянная ссылка на комментарий
sudo apt-get uopdate && sudo apt-get upgrade -y
[аноним]
21.11.2017, 23:06
Постоянная ссылка на комментарий
Помогла очистка листа -
sudo rm -vf /var/lib/apt/lists/*
sudo apt-get update
Linux Mint 18.2 Sonya
[аноним]
06.03.2018, 02:03
Постоянная ссылка на комментарий
перепробовал всё и вот..
W: Репозиторий «//ppa.launchpad.net/tualatrix/ppa/ubuntu xenial Release» не содержит файла Release.
N: Данные из этого репозитория нельзя аутентифицировать, и поэтому потенциально из небезопасно использовать.
N: Смотрите справочную страницу apt-secure(8) о создании репозитория и настройке пользователя.
E: Не удалось получить //ppa.launchpad.net/tualatrix/ppa/ubuntu/dists/xenial/main/binary-amd64/Packages 404 Not Found
E: Некоторые индексные файлы не скачались. Они были проигнорированы или вместо них были использованы старые версии.
[аноним]
12.03.2018, 15:23
Постоянная ссылка на комментарий
Такая же песня...только что поставил xubuntu 17-тую и при установке проигнорил обновы и сейчас всё игнорит чтож за беда то такая...ставил убунту косячить начала..снёс и эту поставил
[аноним]
01.05.2018, 19:19
Постоянная ссылка на комментарий
СПАСИБО ОГРОМНОЕ!!! Мучался целый час гуглил и ничего не помогало, думал из-за старой версии проблемы но нет! Желаю вам счастья и добра в жизни!
[аноним]
22.07.2018, 22:48
Постоянная ссылка на комментарий
Большинство пользователей для установки Linux используют дистрибутивы , включающие не только набор программ, но и решающие ряд задач по обслуживанию, объединённых едиными системами установки, управления и обновления пакетов, настройки и поддержки.
[аноним]
07.11.2018, 14:07
Постоянная ссылка на комментарий
Добрый день! !Пытаюсь обновить Линукс,сразу скажу я чает и все!йник.
Не обновля
VadimAndyАктивный
08.11.2018, 10:41
Постоянная ссылка на комментарийРодительский комментарий
sudo apt update && sudo apt upgrade -y
[аноним]
07.11.2018, 15:48
Постоянная ссылка на комментарий
Как решить эту проблему подскажите пожалуйста?
E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_xenial_main_binary-amd64_Packages, E:The package lists or status file could not be parsed or opened.Не могу ничего сделать.Не обновляется.

Написать комментарий

Ваше имя:
Текст комментария: