Релизы программного комплекта Wine 6.5-6.6. Linux новости
Поддержать

Релизы программного комплекта Wine 6.5-6.6

28
Лайков: +9
войдите, чтобы ставить лайки

Wine 6.5-6.6

Wine 6.5-6.6
Версия:6.5, 6.6
Дата релиза:9 апреля 2021
Предыдущий релиз:6.4 от 12 марта 2021 (пресс-релиз)
Страница:Wine

Состоялись релизы Wine 6.5 и 6.6. Отметим некоторые изменения в новых релизах.

Wine — комплект утилит и библиотек, которые предназначены для запуска WIndows приложений внутри Linux. Wine не является эмулятором, а реализует (транслирует) вызовы Windows API в соответствующие системные вызовы Linux. Компоненты Wine используются в различных игровых сервисах, работающих в Linux.

Что нового

  • Поддержка OpenCL 1.2.
  • Движок Mono обновлен до версии 6.1.1.
  • Библиотеки DWrite и DnsApi сконвертированы в формат PE.
  • Улучшена поддержка драйвера Plug & Play.
  • Улучшена поддержка режимов совместимости Internet Explorer в движке MSHTML.
  • Улучшена поддержка работы компонентов Rich Edit в режиме windowless (Windowless Rich Edit Controls).
  • Исправлены ошибки.

Некоторые программы и игры, для которых были выполнены различные исправления, связанные с работой под Wine:
League of Legends 8.12+, Jedi Knight: Dark Forces II, Guild Wars 2, Adobe Audition 2020, движок Half-Life, Microsoft Flight Simulator, Tony Hawk’s Pro Skater, FlatOut 2, Altium Designer 17, PdfSharp, Solid Edge 15, Nvidia FrameView 1.2, Word 97, Dune 2000 и другие.

28
  • Опубликовано: 11.04.2021

Комментарии

Singular
Активный пользователь
Активный
11.04.2021
19:30
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
+1
войдите, чтобы ставить лайки
OpenCL особенно радует. Надеюсь норм работает на AMD GCN.
Жаль я смогу это проверить после выхода Debian 11. (Не люблю менять дистры)
Мб кто знает, как обстоят дела с Photoshop CC 2020 и 2019? Они норм работают в wine? Можно уходить с windows?
[аноним]
11.04.2021
19:45
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
не пробовал, не знаю.
Mrsvx81
Активный пользователь
Активный
11.04.2021
20:08
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Можно посмотреть в базе приложений на winehq.
Singular
Активный пользователь
Активный
11.04.2021
20:14
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Там красивая стата, что не всегда и не у всех соответствует действительности.
2019 вроде как должен заработать.
Проверю после выхода Debian 11. На десятке не заводится, требует зависимость libfaudio0 которая в свою очередь не хочет работать.
fallen
Активный пользователь
Активный
11.04.2021
20:27
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
https://computingforgeeks.com/how-to-install-wine-on-debian/
Singular
Активный пользователь
Активный
11.04.2021
20:37
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Странно что здесь не указано про ту библиотеку libaudio0
fallen
Активный пользователь
Активный
11.04.2021
20:54
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
https://forum.winehq.org/viewtopic.php?t=32545

https://wine.htmlvalidator.com/winehq-devel-installation.html

https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/Debian_10/i386/
Singular
Активный пользователь
Активный
11.04.2021
21:34
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Та ладно. Не хочу ломать зависимости.
Дождусь Bullseye, там с этим всё норм.
com
11.04.2021
21:42
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
а кто сказал что там всё норм и не прийдется из-за этого ставить ту же убунту?
Singular
Активный пользователь
Активный
12.04.2021
07:09
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Всегда было норм до версии 6.0
И дальше будет.
com
11.04.2021
21:41
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
не факт что такое будет и на 11 может проще поставить убунту там он сразу ставится
AntonZP
Активный пользователь
Активный
11.04.2021
22:03
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
посмотрел эту новость, побежал впереди паровоза.
час назад поставил 6.5 (сейчас сижу на Debian sid)

на моём софте - ничего не изменилось.
com
11.04.2021
22:30
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
ставили по инструкции обычно?
AntonZP
Активный пользователь
Активный
12.04.2021
09:09
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
пытался, но слетел ключ шифрования и там еще было... точно до буквы уже не скажу. пардон.

репозиторий опенсушки подключал.
AntonZP
Активный пользователь
Активный
12.04.2021
11:41
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
сегодня прилетела обнова до 6.6, мне кажется с ней не всё впорядке.
com
12.04.2021
12:28
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
немного с другой темы но ставили debian с образа non-free где wi-fi не завелась?
AntonZP
Активный пользователь
Активный
12.04.2021
13:21
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
wi-fi не завелась на нетбуке, туда wine не ставил.

wine на основном Dell E5520 https://www.notebookcheck.net/Review-Dell-Latitude-E5520-Notebook.60643.0.html

на нём апгрейдил систему со стейбла 10.8
AntonZP
Активный пользователь
Активный
13.04.2021
23:56
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
можете считать что уже вышел, с сегодняшнего дня neofetch пишет:
OS: Debian GNU/Linux 11 (bullseye) x86_64

т.е. пропало слово sid
Степан
11.04.2021
20:12
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Photoshop ворованный?
Singular
Активный пользователь
Активный
12.04.2021
07:10
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
+1
войдите, чтобы ставить лайки
Это не моё. Мне подкинули)
x230
Активный пользователь
Активный
11.04.2021
20:32
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
+2
войдите, чтобы ставить лайки
Трудно сказать. Денег на Фотошоп нет.
Singular
Активный пользователь
Активный
11.04.2021
20:38
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
+2
войдите, чтобы ставить лайки
У меня тоже.
Ну ничего, нам кролик помогает.
Akeshi
11.04.2021
22:38
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
+1
войдите, чтобы ставить лайки
Работает 2019 СС . Если устанавливать с github
Сам работаю на нем. Вроде норм. Система ubuntu 18.04. Даже делал тяжёлые проекты . Единственное не не использовал 3D режим. И бесит , что при добавление шрифтов надо перезаходить . Видит полный объем оперативки.
Singular
Активный пользователь
Активный
12.04.2021
07:36
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Спасибо за комментарий. Именно это я и хотел узнать.
Сам никогда не пользовался 3D в фотошопе.
Главное чтоб OpenCL работал как надо. Для CC2019 и 2020 это важно, многие фильтры работают исключительно на нём.
Мимокрокодил
12.04.2021
07:28
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Попробуйте вот это: https: // github.com/Gictorbit/photoshopCClinux У меня на двух компах стоит. Правда работает не очень стабильно, но мне кажется от железа много зависит.
Singular
Активный пользователь
Активный
12.04.2021
07:39
Постоянная ссылка на комментарийПостоянная ссылка на комментарийРодительский комментарийРодительский комментарий
0
войдите, чтобы ставить лайки
Интересно. В описании не указана поддержка видях от AMD. Других у меня нет.
Demetrum24579
Активный пользователь
Активный
11.04.2021
22:22
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
0
войдите, чтобы ставить лайки
Поддержки vcrun2015 так и нету? На 64-битную версию Wine не ставится, ни на одну, кроме 32
Прохожий
12.04.2021
11:12
Постоянная ссылка на комментарийПостоянная ссылка на комментарий
0
войдите, чтобы ставить лайки
Автокад не заработал?

Написать комментарий

Ваше имя:
Текст комментария:
  • Уважать других.
  • Не ругаться.
  • Без оскорблений.
  • Без грубости.
  • Не переходить на личности.
Правила