Поддержать

Octopi vs Pamac

  • x230x230 02.06.2021
    Сижу на Artix.
    В нём пользовался Памаком, ибо я - сторонник Гуя.
    Консоль иногда идёт в дело, но чаще - Pamac.
    А сегодня (вчера вообще-то) одновременно уронили зеркало (mirrors.dotsrc.org) и обновили Pacman (с версии 5.* на 6).
    новый Пакман пользует библиотеку libalpm.so.13 , пятый - libalpm.so.12.
    Пока игрался (разбирался) с этой "двойной" напастью, убил Pamac. Снова пока поставить не получилось и накатил Octopi, а тот юзает библиотеку libalpm.so.12.
    Её я скопировал с установочной флэшки и подсунул в /usr/lib/.
    Так что сижу, вспоминаю свой первый опыт с Арчами (про Octopi ...) в ожидании "починки" Памака.
    И вот хотелось бы узнать у опытных людей какому менеджеру программ (в Арчах) они отдают предпочтение, ну, если отдают?
  • KittyBlancKittyBlanc 02.06.2021
    x230:
    Сижу на Artix.
    В нём пользовался Памаком, ибо я - сторонник Гуя.
    Консоль иногда идёт в дело, но чаще - Pamac.
    А сегодня (вчера вообще-то) одновременно уронили зеркало (mirrors.dotsrc.org) и обновили Pacman (с версии 5.* на 6).
    новый Пакман пользует библиотеку libalpm.so.13 , пятый - libalpm.so.12.
    Пока игрался (разбирался) с этой "двойной" напастью, убил Pamac. Снова пока поставить не получилось и накатил Octopi, а тот юзает библиотеку libalpm.so.12.
    Её я скопировал с установочной флэшки и подсунул в /usr/lib/.
    Так что сижу, вспоминаю своё первый опыт с Арчами (про Octopi ...) в ожидании "починки" Памака.
    И вот хотелось бы узнать у опытных людей какому менеджеру программ (в Арчах) они отдают предпочтение, ну, если отдают?
    Pamac на GTK, Octopi на Qt
  • x230x230 02.06.2021
    Да, я в курсе, что Pamac - на gtk.
    Иц май фэйворит. Но нынче он не работает, - и я (завтра) начну волноваться.
    Поэтому сегодня установил Octopi и тыкаю в него палочкой.
    Например нажимаю на кнопарь с зеленым человечком, а он мне говорит: а надо установить 'yay-bin' !
    Я ему: валяй!
    А он такой: а вот хрен тебе !
    /bin/bash -c "/home/x230/.config/octopi/yay --noconfirm --noeditmenu -S yay-bin;echo 'Press any key to continue...'"
    :: Checking for conflicts...
    :: Checking for inner conflicts...
     -> 
    Package conflicts found:
     -> Installing yay-bin will remove: pacman (libalpm.so>12-64)
    package conflicts can not be resolved with noconfirm, aborting
    Press any key to continue...
  • x230x230 02.06.2021
    Короче жду когда починят безпредел с libalpm.so.12 или 13
    ...
    Докучи проблема:
    Оказывается у меня в Octopi не работает AUR. - Ставлю pacaur, - нужен yaourt, - пытаюсь ставить yaourt, - посыл в пеший сексуальный тур .... :((
  • AquaVersoAquaVerso 03.06.2021
    Вылезла тоже проблема c pamac, пересобрал из AUR все работает, только не могу обновить pacman до 6-ой версии :))
  • x230x230 03.06.2021
    AquaVerso:
    не могу обновить pacman до 6-ой версии
    А что за дистр?
  • AquaVersoAquaVerso 03.06.2021
    x230:
    AquaVerso:
    не могу обновить pacman до 6-ой версии
    А что за дистр?

    Artix B-)
  • x230x230 03.06.2021
    AquaVerso:
    обновить pacman
    sudo pacman -Syyuu
    Но тогда сломается всё остальное (pamac, octopi)

    ...

    Только что проверил - http://mirrors.dotsrc.org/ заработал .
  • datamandataman 03.06.2021
    x230:
    зеркало (mirrors.dotsrc.org)
    Однажды я сравнивал скорость появления обновлений на различных "зеркалах".
    И теперь использую эти:
    Server = https://eu-mirror.artixlinux.org/repos/$repo/os/$arch
    Server = https://quantum-mirror.hu/mirrors/pub/artix-linux/$repo/os/$arch
    И вот хотелось бы узнать у опытных людей какому менеджеру программ (в Арчах) они отдают предпочтение, ну, если отдают?
    Никакому. Использую всю мощь консольных утилит. :)
  • AquaVersoAquaVerso 03.06.2021
    Пересел с xfce4 на plasma и о чудо pacman -Sy pacman 6-ая версия установилось. Однако теперь ни pamac ни octopi не запускаются :-))
    Что особенного в 6-ой версии pacman? Он стал еще быстрее B-)
  • x230x230 03.06.2021
    Отвечая OldRunner'у (https://pingvinus.ru/gallery/3797#c57334) и Minor'у (https://pingvinus.ru/gallery/3797#c57342) расскажу свои мытарства:
    Установил yay (не без бубна ессно), потом с его помощью установил yaourt, а потом с его помощью установил pacaur. И вот его прописал (включив галочку) в Octopi. Ничего так приключение в один день?. Это я еще не сказал про создание симлинка (вчера правда) на libalpm.so.12.0.2, ибо Octopi требовал. А с симлинками я вообще никогда не сталкивался.
    После всего удалил yay и yaourt, оставив pacaur, он, говорят, корректнее всех. И, да, только сегодня узнал, что всё это (yay, yaourt, pacaur и еще несколько подобных) называются хелперы для Аура.
    Дичь!..

    AquaVerso:
    в 6-ой версии pacman
    Один сцуко в поле воин. А вокруг "трупы" врагов и друзей лежат, - это ничего... Ищу способ как откатить pacman на пятую версию.