JuffEd

Редактор кода
Текущая оценка:
Зарегистрируйтесь, чтобы ставить оценки.
Добавить в мои программыЧто это такое?

Установить JuffEd в Ubuntu:
sudo apt-get install juffed

JuffEd — редактор кода для Linux. Умеет подсвечивать код (синтаксис), поддерживает сворачивание блоков кода, подсвечивание парных скобок и многое другое. Редактор похож по функциональности на Notepad++.

Программу на сайт добавил пользователь Voland, его обзор:
16.10.2012, 09:32
Вы помните свою бытность программистов под Windows? Какой редактор кода (не IDE) был одним из любимых? Правильно — Notepad++. Многие так привыкли к нему, к его функциям и интерфейсу, что используют его в и *nix, запуская под WINE. Большинство юниксоидов считают это глупостью, так думаю и я. Ведь и правда — для чего устанавливать *nix систему, если все равно пользуешься Win софтом? Однако, до недавней поры я прибегал к этой глупости... Но выход есть всегда. В моём случае, этим выходом стал Juffed.

Juffed — это текстовый редактор — по-сути, упрощённая копия Notepad++. Похожая работа с кодировками, схожий с Notepad++ интерфейс. Juffed невероятно легковесный и быстрый — на данный момент, это самый отзывчивый редактор под *nix, в котором я работал.
Редактор имеет внятную подсветку синтаксиса, свёртывание блоков кода, поиск и замену в тексте, плагины и т. д.
Программа основана на библиотеках Qt4, имеются реализации под Linux и Windows.

Скриншоты

Документ с кодом
Скриншот предоставлен пользователем.
Juffed Документ с кодом
Пустой документ
Скриншот предоставлен пользователем.
Juffed Пустой документ
Смотрите также:
Komodo Edit
Редактор кода
Geany
Среда разработки
GEdit
Популярный текстовый редактор
ASCIIQuarium
ASCII аквариум
PlayOnLinux
Windows игры в Linux
LibreOffice Writer
Текстовый процессор
16.10.2012Voland10

Комментарии

Активный
16.10.2012, 11:24
Хорошая программка!

Под Ubuntu можно ставить просто: sudo apt-get install juffed

Правда при запуске выскакивала ошибка: juffed: error while loading shared libraries: libjuff.so.0.9: cannot open shared object file: No such file or directory

Чтобы вылечить, нужно выполнить:
sudo ln -s /usr/lib64/libjuff.so.0.9 /usr/lib/libjuff.so.0.9
Активный
16.10.2012, 11:31
Да, точно, я читал где-то про этот костыль. В Gentoo проблем не возникло.
Активный
16.10.2012, 12:01
На дебиане проблем также нет.
Владимир
16.10.2012, 13:16
А как сделать, чтобы открывал по умолчанию в кодировке win-1251? А то русский шрифте не показывает ввобще, пока не переключишь вручную
Активный
16.10.2012, 15:24
Никак, видимо. Я такой опции там не нашел, по крайней мере.
Андрей
04.04.2013, 19:54
мультиредактирования нет
он бесполезен
Михаил
19.06.2013, 14:12
Как по ФТП подрубиться?
dfcz
10.04.2015, 11:17
нету редактора лучше Notepad++! Почему не могут сделать подсветку закрывающихся тегов, как в нотпаде, не в одной самой мощной ИДЕ такого нет! ПОЧЕМУ? Может кто знает редактор с подсветкой парных тегов для Linux
Активный
10.04.2015, 15:14
>> не в одной самой мощной ИДЕ такого нет
Не самая мощная IDE NetBeans умеет так. Для Geany есть плагин такой подсветки. Kate/KEdit умели, вроде, но точно не вспомню - кедами давно не пользовался.
Ну а JuffEd сдох на стадии разработки. Частое явление, увы.
Dreamod
03.10.2015, 13:33
PhpStorm умеет. И умеет лучше других и Notepad++ в том числе. Шторм позволяет закрывать теги не только сверху вниз, но и снизу вверх, от закрывающего к открывающему, что офигеть как удобно.

Написать комментарий

Ваше имя:
Текст:
Вы не зарегистрированы: комментарий будет опубликован только после просмотра администратором сайта.