Поддержать

Проблема с драйвером видео при старте системы.

  • FoxFox 16.12.2012
    Здравствуйте! Так уж сложилось что я очень требователен к внешнему виду рабочей среды, в данный момент перешел на дистрибутив Elementary OS. (http://pingvinus.ru/distribution/elementary-os)
    С внешним видом здесь все отлично, очень порадовал логотип когда система загружалась с Live usb. Проблема у меня в том что после установки проприетарного драйвера Nvidia, логотип при старте пропадает, чтобы дальше было понятно я говорю о splash screen. Вместо него у меня ломаная надпись Elementary OS и точки внизу. К слову сказать так у меня было с разными дистрибутивами (Ubuntu 12.04,12.10, Mint).
    Собственно совет по правке разрешение в конфигурационном файле граба не помогает, экран загрузки вообще пропадает. Так вот и вопрос мой, как это дело исправить? Как заставить систему, граб или драйвер понять что у меня большое разрешение?
    Для информативности у меня видеокарта Nvidia Geforce 9500GT, и разрешение 1680х1050 px. Драйвер поставил 310 т.к хотел позже в Team Fortress поиграть в стиме..
    Надеюсь на вашу помощь, очень мешает эта проблема.
  • GenomGenom 17.12.2012
    Хм, насколько я знаю система отключает видеодрайвер на этапе загрузки (там типа какой-то конфликт может произойти между видеодрайвером загрузки, назовём его так, и проприетарным). Я покопался у себя в Xubuntu но ничего, к сожалению, не нашёл. Могу только сказать, что искать надо в настройках (там, где настраиваются разные драйвера).
  • FoxFox 17.12.2012
    Genom:
    Хм, насколько я знаю система отключает видеодрайвер на этапе загрузки (там типа какой-то конфликт может произойти между видеодрайвером загрузки, назовём его так, и проприетарным). Я покопался у себя в Xubuntu но ничего, к сожалению, не нашёл. Могу только сказать, что искать надо в настройках (там, где настраиваются разные драйвера).

    Помню когда мучился в 12.04 и в 12.10, один из способов немного помог. Это когда в файле /etc/default/grub прописал GRUB_GFXMODE=1024x768 это помогло немного улучшить качество но у меня разрешение как я выше писал 1680х1050 и поэтому качество все ровно было не ахти. А если еще повыше ставить значение то картинка вообще пропадает.
    Сейчас не пробовал, т.к у меня даже этого самого splash screen нету, только текст.

    Люди на форумах пишут тоже с этой проблемой, некотором помогает способ с GRUB_GFXMODE, другим вот этот Ссылка (http://help.ubuntu.ru/wiki/установка_драйвера_nvidia) его в основном советуют на всех сайтах. И многим помогает, мне же нечего из этого не помогло.

    Собственно, видео драйвер отключен до загрузке системы то может можно где нибудь поменять стандартное разрешение? Помню еще пробовал утилту Grub customizer, с её помощью менял разрешение граба, оно менялось! При выборе ОС шрифт был заметно меньше и четче, но этого самого сплэш скрина (splash screen) не было вообще. Не знаю уже что делать, очень не нравится эта проблема. Помню что когда первый раз поставил 12.04 после кучи перепробованных способов разрешение таки изменилось, точнее в верхнем левом углу была загрузка системы, был видел splash screen но вся правая часть была пустой. Не знаю что еще можно сделать, кто то писал что помогло простое удаление каких то файлов в папке с грабом, я пока не решился экспериментировать с этим.
  • FoxFox 21.12.2012
    UPD 1:

    Помогла статья в которой говорилось раскомментировать в файле /usr/share/nvidia-experimental-310/nvidia-current-updates.grub-gfxpayload строку #v10ded.*sv.*sd.*bc03sc.* . Теперь у меня появляется Splash screen! Осталось решить проблему с его разрешением :(
  • USUBUSUB 28.12.2012
    Если система 12.04, то оптимально, чтобы ничего не падало:
    kernel - максимум 3.4 (по умолчанию сейчас обновляется до 3.2) 3.5,3.6,3.7 - не надо ставить, могут быть
    глюки. На сайте kernel.org для "Precise Pangolin" максимальное ядро на данный момент - 3.4
    С видюхой дела следующие: (я про Нвидию) У них на сайте висит ,что 310-й сейчас stable, а 313-й beta/
    Врут они. Сейчас stable - 304-й.
    На работе стоит 304-й - все "пашет". Дома дурак 2 дня назад обновился до 310-го. - рабочий стол слетел
    тут же после перезагрузки.Откатываться до 304-го нада будет.
    На ubuntovod.ru мужики тоже о 310-м пишут, что глючный.
  • FoxFox 28.12.2012
    USUB:
    Если система 12.04, то оптимально, чтобы ничего не падало:
    kernel - максимум 3.4 (по умолчанию сейчас обновляется до 3.2) 3.5,3.6,3.7 - не надо ставить, могут быть
    глюки. На сайте kernel.org для "Precise Pangolin" максимальное ядро на данный момент - 3.4
    С видюхой дела следующие: (я про Нвидию) У них на сайте висит ,что 310-й сейчас stable, а 313-й beta/
    Врут они. Сейчас stable - 304-й.
    На работе стоит 304-й - все "пашет". Дома дурак 2 дня назад обновился до 310-го. - рабочий стол слетел
    тут же после перезагрузки.Откатываться до 304-го нада будет.
    На ubuntovod.ru мужики тоже о 310-м пишут, что глючный.
    Я если честно и не задумывался на какой версии убунты основана Elementary os, но в любом случае даже с 304 драйвером проблема не решалась. В общем то сейчас проблема стала немного меньше, сначала темный экран потом на секунду появляется логотип и сразу рабочий стол, даже рассмотреть не успеваешь :)
  • USUBUSUB 01.01.2013
    Так и пришлось перед New Year хубунту 12.04 переустанавливать.Переустановил, стал ставить дрова
    через "драйверы устройств", фиг - 304 у кацманафта до сих пор как beta идет. Поставил он мне 297.
    Все пашет. А у этих мудаков на сайте уже 310 - stable. Лишь бы сляпать че-нить.
  • USUBUSUB 01.01.2013
    сейчас нашел, Elementary OS Jupiter based on Ubuntu 10.10.
    Ищите совместимые дрова с этой вкрсией Бубунты - 10.10